re = /^\/([a-zA-Z0-9]*)\/([a-zA-Z0-9-.\_-]*)\/([a-zA-Z0-9-.!:;,^$&|*?@%\_\/-]*)/m
str = '/pods/lscis.gov/request/green-card'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end