#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[01](?:\.0)?|1[01]*(?:\.[01]{0,31}1)?)$"
Local $sString = "1.001100101" & @CRLF & _
"1.0000000000000010" & @CRLF & _
"1" & @CRLF & _
"0" & @CRLF & _
"0.1" & @CRLF & _
"1..1" & @CRLF & _
"1.1" & @CRLF & _
"1.000000000000001" & @CRLF & _
"1.01010101010101010101010101010101" & @CRLF & _
"1.010101010101010101010101010101011" & @CRLF & _
"0.0" & @CRLF & _
"1.0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")