# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[01](?:\.0)?|1[01]*(?:\.[01]{0,31}1)?)$"
test_str = ("1.001100101\n"
"1.0000000000000010\n"
"1\n"
"0\n"
"0.1\n"
"1..1\n"
"1.1\n"
"1.000000000000001\n"
"1.01010101010101010101010101010101\n"
"1.010101010101010101010101010101011\n"
"0.0\n"
"1.0\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.