#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^aa(?:aa)*b(?:bbb)*$(*SKIP)(*FAIL)|^.*$"
Local $sString = "a" & @CRLF & _
"b" & @CRLF & _
"ab" & @CRLF & _
"aab" & @CRLF & _
"abb" & @CRLF & _
"aaab" & @CRLF & _
"aabb" & @CRLF & _
"abbb" & @CRLF & _
"aaaab" & @CRLF & _
"aaabb" & @CRLF & _
"aabbb" & @CRLF & _
"abbbb" & @CRLF & _
"aaaaab" & @CRLF & _
"aaaabb" & @CRLF & _
"aaabbb" & @CRLF & _
"aabbbb" & @CRLF & _
"abbbbb" & @CRLF & _
"aaaaaab" & @CRLF & _
"aaaaabb" & @CRLF & _
"aaaabbb" & @CRLF & _
"aaabbbb" & @CRLF & _
"aabbbbb" & @CRLF & _
"abbbbbb" & @CRLF & _
"aaaabbbb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")