import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^aa(?:aa)*b(?:bbb)*$(*SKIP)(*FAIL)|^.*$";
final String string = "a\n"
+ "b\n"
+ "ab\n"
+ "aab\n"
+ "abb\n"
+ "aaab\n"
+ "aabb\n"
+ "abbb\n"
+ "aaaab\n"
+ "aaabb\n"
+ "aabbb\n"
+ "abbbb\n"
+ "aaaaab\n"
+ "aaaabb\n"
+ "aaabbb\n"
+ "aabbbb\n"
+ "abbbbb\n"
+ "aaaaaab\n"
+ "aaaaabb\n"
+ "aaaabbb\n"
+ "aaabbbb\n"
+ "aabbbbb\n"
+ "abbbbbb\n"
+ "aaaabbbb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}