const regex = /(?=^[01]*$)^(.).*\1|.$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^[01]*$)^(.).*\\1|.$', 'gm')
const str = `10001001001aaba
100100001001
0001001001010
0
1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}