$re = '/(?=^[01]*$)^(.).*\1|.$/m';
$str = '10001001001aaba
100100001001
0001001001010
0
1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);