package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^((http[s]?):\/)?\/?([^:\/\s]+)((amazonaws)*\/)([\w-\.]+[^#?\s]+)`)
var str = `https://s3-us-west-2.amazonaws.com/offer-creatives-dev-cdn/3455-422D9D55A6F5C55D5D9B508386FF0DA3231AD489.jpg
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}