const regex = /^((http[s]?):\/)?\/?([^:\/\s]+)((amazonaws)*\/)([\w-\.]+[^#?\s]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((http[s]?):\\\/)?\\\/?([^:\\\/\\s]+)((amazonaws)*\\\/)([\\w-\\.]+[^#?\\s]+)', 'gmi')
const str = `https://s3-us-west-2.amazonaws.com/offer-creatives-dev-cdn/3455-422D9D55A6F5C55D5D9B508386FF0DA3231AD489.jpg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}