$re = '/^[^(]+(?=$|\s)/m';
$str = 'Today is a beautiful day (Monday)
Today is a beautiful day';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);