re = /^[^(]+(?=$|\s)/m
str = 'Today is a beautiful day (Monday)
Today is a beautiful day'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end