#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\A[a-z][a-z0-9.+-]*:\/\/(\w+:{0,1}\w*@)?([^:\/]+)(:[0-9]+)?(\/|\/([\w#!:.?+=&%@!\-\/]))?\z"
Local $sString = "https://www.openstreetmap.org/diary"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")