$re = '/\A[a-z][a-z0-9.+-]*:\/\/(\w+:{0,1}\w*@)?([^:\/]+)(:[0-9]+)?(\/|\/([\w#!:.?+=&%@!\-\/]))?\z/m';
$str = 'https://www.openstreetmap.org/diary';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);