$re = '/^(?:\d{4}-){4}\d{3}$/m';
$str = '5077-1200-5007-3284-951
5077-1200-5007-3284-951123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);