re = /^(?:\d{4}-){4}\d{3}$/m
str = '5077-1200-5007-3284-951
5077-1200-5007-3284-951123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end