const regex = /(?x)
(?(DEFINE)
(?<nrun> [0-9]+)
(?<range> (?&nrun) (-(?&nrun))? )
(?<sep> ,)
)
^( (?&range) ((?&sep)|$) )+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x)
(?(DEFINE)
(?<nrun> [0-9]+)
(?<range> (?&nrun) (-(?&nrun))? )
(?<sep> ,)
)
^( (?&range) ((?&sep)|$) )+$', 'gm')
const str = `^((^|,)([0-9]+(-[0-9]+)?(,|\$))+)\$
1,2,3-5,6
1,2,3-5,6,
1
1-3
,1,2,3
23,25-89,99
23,12,3-5,15
1,2,3-,4,5-7
1,2,3-,4,5-7,
1,2,-3,4,5
1,2,-,3,4
1,2,,,3,4
1a2-2aoe
abc2-23ght`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}