import Foundation
let pattern = #"""
(?x)
(?(DEFINE)
(?<nrun> [0-9]+)
(?<range> (?&nrun) (-(?&nrun))? )
(?<sep> ,)
)
^( (?&range) ((?&sep)|$) )+$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
^((^|,)([0-9]+(-[0-9]+)?(,|$))+)$
1,2,3-5,6
1,2,3-5,6,
1
1-3
,1,2,3
23,25-89,99
23,12,3-5,15
1,2,3-,4,5-7
1,2,3-,4,5-7,
1,2,-3,4,5
1,2,-,3,4
1,2,,,3,4
1a2-2aoe
abc2-23ght
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)