#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\W{3}(\s|\s\s)(“|")\W{1,}\d+\W+\d+|(^\W+:|^.{1,}:)(\s|\s\s)\W{1,}\d{1,}\s\W{1,}\d{1,}(\s|\s\s)\W+)"
Local $sString = "Сбербанк России ОАО г.Москва" & @CRLF & _
"Банк получателя" & @CRLF & _
"инн 502204278650" & @CRLF & _
"Внимание' Оплата данного счета означает согласие с условиями поставки товара. Уведомление об оплате" & @CRLF & _
"обязательно, в противном случае не гарантируется наличие товара на складе товар отпускается пс факту" & @CRLF & _
"прихода денег на prc Поставщика. самовывозам, при наличии довереанссти а паспорта" & @CRLF & _
"Образец заполнения платежного поручения" & @CRLF & _
"70 шт" & @CRLF & _
"кпп о" & @CRLF & _
"Сч. N?" & @CRLF & _
"Сч, N?" & @CRLF & _
"044525225" & @CRLF & _
"30101810400000000225" & @CRLF & _
"40802810740200101005" & @CRLF & _
"Краснова Татьяна Валерьевна”" & @CRLF & _
"Пол атель" & @CRLF & _
"Счет N? 196 от 17.12.08" & @CRLF & _
"инн 502204278650 КПП o" & @CRLF & _
"Поставщик:" & @CRLF & _
"“ИП Краснова Татьяна Валерьевна“" & @CRLF & _
"140411, Рф, Моск. обл.,г.Коломна,ул.Зеленая,д.ВА,кв.9" & @CRLF & _
"Покупатель: ИНН 5022017021 КПП 502201001 околоменский дом ребенка“" & @CRLF & _
"2" & @CRLF & _
"Товар" & @CRLF & _
"крем ЛАСКОВАЯ МАМА детский л 20мп Москва" & @CRLF & _
"Шампунь детский ЛАСКОВАЯ МАМА звомлг•пераое" & @CRLF & _
"шение“" (Москва" & @CRLF & _
"КОЛ-ВО" & @CRLF & _
"96" & @CRLF & _
"Ед." & @CRLF & _
"Цена" & @CRLF & _
"Итого:" & @CRLF & _
"Сумма" & @CRLF & _
"3360 ос" & @CRLF & _
"2Ђва 00" & @CRLF & _
"6'048.00" & @CRLF & _
"Всего наименований 2. на сумму 6048,00 руб." & @CRLF & _
"Шесть тысяч сорок восемь рублей 00 копеек" & @CRLF & _
"Руководитель" & @CRLF & _
"[Краснова Т.В.}" & @CRLF & _
"Бухгалтер" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")