const regex = /(?:value|client)\s*=\s*([^,\r\n]*?)(?=\s*,|\s*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:value|client)\\s*=\\s*([^,\\r\\n]*?)(?=\\s*,|\\s*$)', 'gm')
const str = `isLogIn=true; Max-Age=400; Path=/; Expires=Wed, 25 Sep 2019 17:46:30 GMT, value=qasde% , client=retail
isLogIn=true; Max-Age=400; Path=/; Expires=Wed, 25 Sep 2019 17:46:30 GMT, value = qasde% , client = retail `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}