re = /(?:value|client)\s*=\s*([^,\r\n]*?)(?=\s*,|\s*$)/m
str = 'isLogIn=true; Max-Age=400; Path=/; Expires=Wed, 25 Sep 2019 17:46:30 GMT, value=qasde% , client=retail
isLogIn=true; Max-Age=400; Path=/; Expires=Wed, 25 Sep 2019 17:46:30 GMT, value = qasde% , client = retail '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end