using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(-\w+)?(?!\\)\((.*)(?<!\\)\)";
string input = @"sepia(0)
grayscale(0)
brightness(1)
blur(0px)
contrast(1)
invert(0)
saturate(1)
drop-shadow(rgb(0, 0, 0) 0px 0px 0px)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}