const regex = /\w+(-\w+)?(?!\\)\((.*)(?<!\\)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+(-\\w+)?(?!\\\\)\\((.*)(?<!\\\\)\\)', 'gm')
const str = `sepia(0)
grayscale(0)
brightness(1)
blur(0px)
contrast(1)
invert(0)
saturate(1)
drop-shadow(rgb(0, 0, 0) 0px 0px 0px)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}