package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:\.\d+){3}(?::\d+)?$`)
var str = `127.0.0.1
127.0.0.1:8181`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}