$re = '/^\d+(?:\.\d+){3}(?::\d+)?$/m';
$str = '127.0.0.1
127.0.0.1:8181';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);