$re = '/(?!\(\*\*\))MUST(?!\(\*\*\))/m';
$str = 'This MUST should be caught, but not this one **MUST** because it is between **
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);