re = /(?!\(\*\*\))MUST(?!\(\*\*\))/m
str = 'This MUST should be caught, but not this one **MUST** because it is between **
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end