using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((r|🇷)+)(( |\n)*)((🇪|e)+)(( |\n)*)((p|🇵)+)(( |\n)*)((🇴|o|O)+)(( |\n)*)((🇸|s)+)(( |\n)*)((t|🇹)+)";
string input = @"r 🇪 p O s t
r e post";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}