package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((r|🇷)+)(( |\n)*)((🇪|e)+)(( |\n)*)((p|🇵)+)(( |\n)*)((🇴|o|O)+)(( |\n)*)((🇸|s)+)(( |\n)*)((t|🇹)+)`)
var str = `r 🇪 p O s t
r e post`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}