#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)value="(\d+),(\d+),(\d+),(\d+)""
Local $sString = "<classifier id="box-geometry" value="476,736,703,997" />" & @CRLF & _
"<classifier id="box-geometry" value="476,736,703, 997" />" & @CRLF & _
"<classifier id="box-geometry" value="476, 736, 703, 997" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")