re = /value="(\d+),(\d+),(\d+),(\d+)"/m
str = '<classifier id="box-geometry" value="476,736,703,997" />
<classifier id="box-geometry" value="476,736,703, 997" />
<classifier id="box-geometry" value="476, 736, 703, 997" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end