$re = '/^([^|]*\|)([^|]*\|)\n\s*([^|\n]*\n)/m';
$str = '"2021-05-13"|"test"|"perfect line"
"2021-05-13"|"test"|
"imperfect line"
"2021-05-13"|"test"|"perfect line"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);