re = /^([^|]*\|)([^|]*\|)\n\s*([^|\n]*\n)/m
str = '"2021-05-13"|"test"|"perfect line"
"2021-05-13"|"test"|
"imperfect line"
"2021-05-13"|"test"|"perfect line"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end