$re = '/\d+\/page/m';
$str = 'https://site.com/05/page/special.html
https://site.com/666/page/error.html
https://site.com/rd/page/error.html
https://site.com/redirect/pages/special.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);