// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+\/page").unwrap();
let string = "https://site.com/05/page/special.html
https://site.com/666/page/error.html
https://site.com/rd/page/error.html
https://site.com/redirect/pages/special.html";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}