#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?<touncomment>^#hostname=hostname2\b)|(?<tocomment>^[^#]\w+=(?!hostname2).*)"
Local $sString = "hostName=hostName1" & @CRLF & _
"#hostName=hostName2" & @CRLF & _
"hostName=hostName2" & @CRLF & _
"#hostName=hostName22" & @CRLF & _
"portNum=portNum1" & @CRLF & _
"#portNum=portNum2" & @CRLF & _
"hostName=hostName1 " & @CRLF & _
"#hostName=hostName2 " & @CRLF & _
"portNum=portNum1 " & @CRLF & _
"portNum=portNum2 " & @CRLF & _
"#portNum=portNum2 " & @CRLF & _
"#portNum=portNum2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")