$re = '/(?i)(?<touncomment>^#hostname=hostname2\b)|(?<tocomment>^[^#]\w+=(?!hostname2).*)/m';
$str = 'hostName=hostName1
#hostName=hostName2
hostName=hostName2
#hostName=hostName22
portNum=portNum1
#portNum=portNum2
hostName=hostName1
#hostName=hostName2
portNum=portNum1
portNum=portNum2
#portNum=portNum2
#portNum=portNum2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);