$re = '/(\/\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|(\/\/.*)/m';
$str = 'app.on(\'activate\', function () {
// On macOS it\'s common to re-create a window in the app when the
// dock icon is clicked and there are no other windows open.
if (mainWindow === null) {
createWindow() //inline comment
}
})
// In this file you can include the rest of your app\'s specific main process
// code. You can also put them in separate files and require them here.
/*
multi line comment
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);