import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m),\"(\"[^\"]*(?:\"\"[^\"]*)*\")\"$";
final String string = "comment_ID\",\"post_ID\",\"product_SKU\",\"comment_author\",\"author_mail\",\"author_location\",\"date\",\"comment\"\n"
+ "\"100\",\"60574\",\"VID17\",\"Jordi\",\"\",\"\",\"2021-06-02 16:20:30\",\"\"My son likes this video, good job\"\"\n"
+ "\"101\",\"60574\",\"VID18\",\"Scarlett,\"\",\"\",\"2020-12-29 23:06:32\",\"\"I don't like this video, it may be better\"\"";
final String subst = ",$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}