re = /(?m),"("[^"]*(?:""[^"]*)*")"$/m
str = 'comment_ID","post_ID","product_SKU","comment_author","author_mail","author_location","date","comment"
"100","60574","VID17","Jordi","","","2021-06-02 16:20:30",""My son likes this video, good job""
"101","60574","VID18","Scarlett,"","","2020-12-29 23:06:32",""I don\'t like this video, it may be better""'
subst = ',$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result