#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^STATEMENT:\s*(?<statement>[^\n]*)(\nERROR:\s*(?<error>[^\n]*))(\nDETAIL:\s*(?<detail>[^\n]*))"
Local $sString = "ERROR: duplicate key value violates unique constraint "ml2_vxlan_endpoints_pkey"" & @CRLF & _
"DETAIL: Key (ip_address)=(10.60.3.132%10200) already exists." & @CRLF & _
"STATEMENT: INSERT INTO ml2_vxlan_endpoints (ip_address, udp_port, host) VALUES ('10.60.3.132%10200', 4789, NULL)" & @CRLF & _
"ERROR: duplicate key value violates unique constraint "ml2_vxlan_endpoints_pkey"" & @CRLF & _
"DETAIL: Key (ip_address)=(10.60.3.131%10200) already exists." & @CRLF & _
"STATEMENT: INSERT INTO ml2_vxlan_endpoints (ip_address, udp_port, host) VALUES ('10.60.3.131%10200', 4789, NULL)" & @CRLF & _
"ERROR: insert or update on table "ml2_dvr_port_bindings" violates foreign key constraint "ml2_dvr_port_bindings_port_id_fkey"" & @CRLF & _
"DETAIL: Key (port_id)=(55ce4ed0-0d40-4e7b-8753-f9f642d03282) is not present in table "ports"." & @CRLF & _
"STATEMENT: INSERT INTO ml2_dvr_port_bindings (port_id, host, router_id, vif_type, vif_details, vnic_type, profile, status) VALUES ('55ce4ed0-0d40-4e7b-8753-f9f642d03282', 'd2c-76-8a-ac-63-e2', '014b66c0-ad4b-48d4-ad89-d57ed543d9d3', 'unbound', '', 'normal', '', 'DOWN')" & @CRLF & _
"ERROR: duplicate key value violates unique constraint "ml2_vxlan_endpoints_pkey"" & @CRLF & _
"DETAIL: Key (ip_address)=(10.60.3.132%10200) already exists." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")