import re
regex = re.compile(r"^STATEMENT:\s*(?<statement>[^\n]*)(\nERROR:\s*(?<error>[^\n]*))(\nDETAIL:\s*(?<detail>[^\n]*))", flags=re.MULTILINE)
test_str = ("ERROR: duplicate key value violates unique constraint \"ml2_vxlan_endpoints_pkey\"\n"
"DETAIL: Key (ip_address)=(10.60.3.132%10200) already exists.\n"
"STATEMENT: INSERT INTO ml2_vxlan_endpoints (ip_address, udp_port, host) VALUES ('10.60.3.132%10200', 4789, NULL)\n"
"ERROR: duplicate key value violates unique constraint \"ml2_vxlan_endpoints_pkey\"\n"
"DETAIL: Key (ip_address)=(10.60.3.131%10200) already exists.\n"
"STATEMENT: INSERT INTO ml2_vxlan_endpoints (ip_address, udp_port, host) VALUES ('10.60.3.131%10200', 4789, NULL)\n"
"ERROR: insert or update on table \"ml2_dvr_port_bindings\" violates foreign key constraint \"ml2_dvr_port_bindings_port_id_fkey\"\n"
"DETAIL: Key (port_id)=(55ce4ed0-0d40-4e7b-8753-f9f642d03282) is not present in table \"ports\".\n"
"STATEMENT: INSERT INTO ml2_dvr_port_bindings (port_id, host, router_id, vif_type, vif_details, vnic_type, profile, status) VALUES ('55ce4ed0-0d40-4e7b-8753-f9f642d03282', 'd2c-76-8a-ac-63-e2', '014b66c0-ad4b-48d4-ad89-d57ed543d9d3', 'unbound', '', 'normal', '', 'DOWN')\n"
"ERROR: duplicate key value violates unique constraint \"ml2_vxlan_endpoints_pkey\"\n"
"DETAIL: Key (ip_address)=(10.60.3.132%10200) already exists.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")