package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z]{2,3}-[0-9]{3}`)
var str = `BR-101
ABC-100
ZZ-000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}