$re = '/[A-Z]{2,3}-[0-9]{3}/';
$str = 'BR-101
ABC-100
ZZ-000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);