#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!.*\bignore\b).*\bapp prod\b.*"
Local $sString = "1. blah app prod blah blah" & @CRLF & _
"2. blah app prod blah ignore" & @CRLF & _
"3. blah app staging blah blah" & @CRLF & _
"4. blah app staging blah ignore" & @CRLF & _
"5. blah app prod blah blah blah ignore blah blah" & @CRLF & _
"6. blah blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")