re = /(?!.*\bignore\b).*\bapp prod\b.*/m
str = '1. blah app prod blah blah
2. blah app prod blah ignore
3. blah app staging blah blah
4. blah app staging blah ignore
5. blah app prod blah blah blah ignore blah blah
6. blah blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end