package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([A-Za-z\xC0-\xD6\xD8-\xf6\xf8-\xff\s]*)$`)
var str = `Bøtte`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}