$re = '/^([A-Za-z\xC0-\xD6\xD8-\xf6\xf8-\xff\s]*)$/';
$str = 'Bøtte';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);