package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z]{4}[0-9]{4}[a-zA-Z]{2}`)
var str = `abcd1234yz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}