$re = '/[a-zA-Z]{4}[0-9]{4}[a-zA-Z]{2}/m';
$str = 'abcd1234yz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);