import re
regex = re.compile(r"(?<=m)(2|3)")
test_str = ("superscript\n"
"(?<=m)(2|3)\n"
"®|™\n"
"(?<=\\d)(de|ème)\n"
"REF\n"
"\\d{6}/(D|T|X)\n"
"REF2\n"
"\\d{3}/(D|T|X)\n"
"REF3\n"
"\\d{6}(?-)\n"
"VET\n"
"garantie[^\\r\\n]+jaar\n"
"Fraction\n"
"\\b1/2\\b\n\n"
"PARQUET STRATIFIE ‘MEGALOFT’\n"
"Différents motifs \n"
"Longueur 1286mm x largeur \n"
"194mm \n"
"10000kcal/u\n"
"25mm2\n"
"10dm3 10dm3/u\n"
"1000m3/u\n"
"850l/u\n"
"1000m3/h\n"
"850l/h\n"
"1,99m2/pak\n"
"1,33m3\n"
"1,25m2\n"
"25kg \n"
"700559/D\n"
"1,59m3/pak\n"
"1,996m2/paquet\n"
"700496-123566-123/D\n"
"1,996m2/paquet\n"
"123566-123/D\n"
"1,99m2 en 199m3/h\n"
"135234-123/D\n\n\n"
"Gerst 004729/D\n"
"Schors 058157/D\n"
"Ø 30/60 x H230cm\n"
"Polyester doek 280gr/m2\n"
"Crossover®-ontstekingssysteem\n"
"™ Toelatingsnr: 3001B\n"
"32/38mm slang\n"
"ZANDFILTERKIT 10m3/u\n"
"Debiet 1,2m2/u\n"
"Zinklaag: 180-250gr/m2\n"
"2de handgreep\n"
"2ème poignon\n"
"Garantie 25 jaar\n"
"10 jaar waarborg\n"
"Maaihoogteregeling 20-75mm\n\n\n"
"Gerst 004729/D\n"
"Schors 058157/D\n"
"Ø 30/60 x H230cm\n"
"Polyester doek 280gr/m2\n"
"Crossover®-ontstekingssysteem\n"
"™ Toelatingsnr: 3001B\n"
"32/38mm slang\n"
"ZANDFILTERKIT 10m3/u\n"
"Debiet 1,2m2/u\n"
"Zinklaag: 180-250gr/m2\n"
"2de handgreep\n"
"2ème poignon\n"
"garantie 25 jaar\n"
"garantie 25 jaar\n"
"Garantie 25 ans jar\n"
"Jaar Garantie 25 \n"
"25 jaar garantie\n"
"10 jaar waarborg\n"
"Maaihoogteregeling 20-75mm\n"
"1/2\n"
"®\n"
"541358/9/60\n"
"541358-12-12/D\n"
"541358-123-123/D\n"
"541358-1234-1234/D\n"
"541358-12345-12345/D\n"
"541358-123456-123456/D")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")